Problem:

A cast-iron bell-crank lever, depicted in the figure below is acted upon by forces $F_1$ of 250 lb and $F_2$ of 333 lb. The section A-A at the central pivot has a curved inner surface with a radius of $r_i = 1$ in. A peg protrudes from the bottom hole, and $F_3$ is applied on the end peg in the direction shown. Estimate the stresses at the inner and outer surfaces of the curved portion of the lever.

Bell Crank

Overview

Anticipated time to complete this tutorial: 1-2 hour

Tutorial Overview
This tutorial is divided into six parts:
1) Tutorial Basics
2) Starting Ansys
3) Preprocessing
4) Solution
5) Post-Processing
6) Hand Calculations

Audience
This tutorial assumes minimal knowledge of ANSYS 8.0; therefore, it goes into moderate detail to explain each step. More advanced ANSYS 8.0 users should be able to complete this tutorial fairly quickly.

Prerequisites
1) ANSYS 8.0 in house “Structural Tutorial”

Objectives
1) Model the bell crank in ANSYS 8.0
2) Analyze the bell crank for maximum stress

Outcomes
1) Learn how to start Ansys 8.0
2) Gain familiarity with the graphical user interface (GUI)
3) Learn how to create and mesh a simple geometry
4) Learn how to apply boundary constraints and solve problems
In this tutorial:
• Instructions appear on the left.

• Visual aids corresponding to the text appear on the right.

• All commands on the toolbars are labeled. However, only operations applicable to the tutorial are explained.

The instructions should be used as follows:

• **Bold** > Text in bold are buttons, options, or selections that the user needs to click on

Example: > Preprocessor > Element Type > Add/Edit/DeleteFile would mean to follow the options as shown to the right to get you to the **Element Types** window

• *Italics* Text in italics are hints and notes

• **MB1** Click on the left mouse button

• **MB2** Click on the middle mouse button

• **MB3** Click on the right mouse button

Some basic ANSYS functions are:

To **rotate** the models use **Ctrl** and **MB3**.

To **zoom** use **Ctrl** and **MB2** and move the mouse **up and down**.

To **translate** the models use **Ctrl** and **MB1**.
For this tutorial the windows version of ANSYS 8.0 will be demonstrated. The path below is one example of how to access ANSYS; however, this path will not be the same on all computers.

For Windows XP start ANSYS by either using:

> Start > All Programs > ANSYS 8.0
> ANSYS
or the desktop icon (right) if present.

Note: The path to start ANSYS 8.0 may be different for each computer. Check with your local network manager to find out how to start ANSYS 8.0.
Once ANSYS 8.0 is loaded, two separate windows appear: the main ANSYS Advanced Utility Window and the ANSYS Output Window.

The ANSYS Advanced Utility Window, also known as the Graphical User Interface (GUI), is the location where all the user interface takes place.

The Output Window documents all actions taken, displays errors, and solver status.
The main utility window can be broken up into three areas. A short explanation of each will be given.

First is the **Utility Toolbar**:

From this toolbar you can use the command line approach to ANSYS and access multiple menus that you can’t get to from the main menu.

*Note: It would be beneficial to take some time and explore these pull down menus and familiarize yourself with them.*

Second is the **ANSYS Main Menu** as shown to the right. This menu is designed to use a top down approach and contains all the steps and options necessary to properly pre-process, solve, and postprocess a model.

Third is the **Graphical Interface** window where all geometry, boundary conditions, and results are displayed.

The tool bar located on the right hand side has all the visual orientation tools that are needed to manipulate your model.
With ANSYS 8.0 open select > File > Change Jobname and enter a new job name in the blank field of the change jobname window.

Enter the problem title for this tutorial. > Ok

In order to know where all the output files from ANSYS will be placed, the working directory must be set in order to avoid using the default folder: C:\Documents and Settings.

> File > Change Directory > then select the location that you want all of the ANSYS files to be saved.

Be sure to change the working directory at the beginning of every problem.

With the jobname and directory set the ANSYS database (.db) file can be given a title. Following the same steps as you did to change the jobname and the directory, give the model a title.
To begin the analysis, a preference needs to be set.

> Main Menu > Preferences

Place a check mark next to the **Structural** box. This determines the type of analysis to be performed in ANSYS.

> Ok

The ANSYS Main Menu should now be opened. Click once on the “+” sign next to Preprocessor.

> Main Menu > Preprocessor

The Preprocessor options currently available are displayed in the expansion of the Main Menu tree as shown to the right.
As mentioned previously, the ANSYS Main Menu is designed in such a way that one should start at the beginning and work towards the bottom of the menu in preparing, solving, and analyzing your model.

Note: This procedure will be shown throughout the tutorial.

Select the “+” next to Element Type or click on Element Type. The extension of the menu is shown to the right.

> Element Type

Select Add/Edit/Delete and the Element type window appears. Select add and the Library of Element Types window appears.

> ADD/EDIT/DELETE > Add

In this window, select the types of elements to be defined and used for this problem.

For this model Solid185 elements will be used.

> Solid > 8node 185
> Ok

In the Element Types window SOLID185 should be visible signaling that the element type has been chosen.

Close the Element Types window.

> Close
The material properties for the SOLID185 elements now need to be defined.
> Preprocessor > Material Props
> Material Models

The Define Material Models Behavior window should now be open.

This window has many different possibilities for defining the materials for your model. We will use isotropic linearly elastic structural properties.

Select the following from the Material Models Available window:
> Structural > Linear > Elastic
> Isotropic

The window titled Linear Isotropic Properties for Material Number 1 now appears. This window is the entry point for the material properties to be used for the model.

Enter $30e6$ (30 Mpsi) in for $\text{EX}$ (Young’s Modulus) and 0.3 for $\text{PRXY}$ (Poisson’s Ratio).
> Ok

Close the Define Material Model Behavior window.
> Material > Exit
The next step is to define the keypoints (KP’s) from which the geometry will be created:

> Preprocessor > Modeling
> Create > Keypoints > In Active CS

The Create Keypoints in Active CS window will now appear. Here the KP’s will be given numbers and their respective (XYZ) coordinates.

Enter the KP numbers and coordinates for the bell crank definition. Select Apply after each KP has been defined.

Note: Be sure to change the keypoint number every time you click apply to finish adding a keypoint. If you don’t it will just move the last keypoint you entered to the new coordinates you just entered.

Select Ok when complete.

In the case that a mistake was made in creating the keypoints, select:

> Preprocessor > Modeling > Delete Keypoints

Select the inappropriate KP’s and select Ok.

The created KP’s should look similar to the example to the right except the KP’s could be labeled with the KP numbers.
At times it will be helpful to turn on the key-point numbers.

> PlotCtrls > Numbering > put a checkmark next to keypoint numbers > OK

Other numbers (for lines, areas, etc.) can be turned on in a similar manner.

The next step is to create lines between the KP’s.

> Preprocessor > Modeling > Create > Lines > Lines > Straight Lines

The Create Straight Lines window should appear. You will create 4 straight lines. Create line 1 between keypoints 72 and 73.

For line 1: MB1 KP 72 then MB1 KP 73.

The other lines will be created in a similar manner.

For line 2: MB1 KP 80 then MB1 KP 79.
For line 3: MB1 KP 74 then MB1 KP 75.
For line 4: MB1 KP 78 then MB1 KP 77.

Verify that each line only goes between the specified keypoints. When you are done creating the straight lines click ok in the Create Straight Lines window.

> Ok

If you make a mistake, use the following to delete the lines:

> Preprocessor > Modeling > Delete > Lines Only
The next step is to create 2 arcs, one at each end of the bell crank.

- Preprocessor > Modeling
  - Create > Arcs > Through 3 KPs

The **Arc Thru 3 KPs window** should appear. Create arc 1 between keypoints 72, 80 and 81.

For line 1: **MB1 KP 72** then **MB1 KP 80** and finally **MB1 KP 81**.

The other arc will be created using By End KPs & Radius.

- Preprocessor > Modeling
  - Create > Arcs
  - By End KPs & Radius

The **Arc By End KPs & Radius window** should appear.
Select keypoints 75 and 77.
   > Ok

Select Keypoint 76.
   > Ok

The Arc by End KPs & Radius window should appear. Enter -1.25 for the radius
   > Ok

Verify that each arc only goes between the specified keypoints.

The next step is to create 2 lines that are tangent to both straight lines created.
   > Preprocessor > Modeling
   > Create > Lines > Lines
   > Tangent to Line

The Line Tangent to Line window should appear. Select the straight line created between Keypoints 72 and 73.
   > Ok

Select Keypoint 73.
   > Ok

Select Keypoint 74.
   > Ok

A line tangent to both straight line should have been created.

Repeat the above steps for the line between keypoints 79 and 78.

Your model should look similar to what is shown to the right.
You are now ready to add the circular shapes that will be extruded.

Change the Work Plane setting from Cartesian to Polar.

> WorkPlane > WP Settings

The WP Settings window should appear. Select Polar at the very top of the WP Settings window.

> Ok

If the Work Plane does not appear at the origin, you will need to offset the WP by Keypoints.

> WorkPlane > Offset WP with

> Keypoints

The Offset WP with Keypoints window should appear. Select Keypoint 1.

> Ok

A similar grid should appear at the Origin.
The next step is to create 2 circles where the WorkPlane is located.

> Preprocessor > Modeling
> Create > Lines > Arcs > Full Circle

The Full Circle window should appear. Change Global Cartesian to WP Coordinates. Enter 0,0,0 in the white box under Global Cartesian and press the return key on the keyboard. Then enter .5625 in the same box.

> Apply

Using the same center (0,0,0), create a second circle of radius .9375

> Ok

Align the WorkPlane with Keypoint 8.

> WorkPlane > Offset WP with
> Keypoints

Select Keypoint 8.

> Ok

Create the same circles you created at Keypoint 1 but now at Keypoint 8.

Your model should look similar to the one shown to the right.
Move the WorkPlane to Keypoint 7.
  > WorkPlane > Offset WP with
  > Keypoints

Select Keypoint 7.
  > Ok

Rotate the Polar WorkPlane at a 55 degree angle counterclockwise (+Z).
  > WorkPlane
  > Offset WP by Increments

The Offset WP window should appear.

Increase the degree angle to 55.
  £ +Z > Ok

The next step is to create the same 2 circles where the WorkPlane is located.
  > Preprocessor > Modeling
  > Create > Arcs > Full Circle

The Full Circle window should appear. Change Global Cartesian to WP Coordinates. Enter 0,0,0 in the white box under Global Cartesian and press the return key on the keyboard. Then enter .5625 in the same box.
  > Apply

Using the same center (0,0,0), create a second circle of radius .9375
  > Ok

To remove the working plane
  > WorkPlane
  > Display Working Plane

With all the lines created, your model should be similar to the one shown on the right.
Now that all the lines of the model have been created, it needs to be filled as a solid.

> Preprocessor > Modeling
> Create > Areas > Arbitrary
> By Lines

The Create Area by Lines window should appear.

Select all four lines of one of the smaller circles.

> Apply

Repeat for the other two small circles. Your model should be similar to what is shown to the right.

Select all four lines of one of the bigger circles.

> Apply

Repeat for the other two big circles. You will now perform a boolean operation to subtract the smaller circle from the bigger.

> Preprocessor > Modeling
> Operate > Boolean > Subtract
> Area

The Subtract Areas window should appear. First select the area from which you will subtract (bigger circle).

> Ok

Then select the area to subtract (smaller circle)

> Ok

Repeat for the other two circular areas created.
Recreate 3 areas around the smaller circle to subtract from the main body.

- Preprocessor > Modeling
- Create > Areas > Arbitrary
- By Lines

Create an area around the outside lines of the model. Your model should look similar to what is shown to the right.

Subtract all 3 circle areas recreated from main body

- Preprocessor > Modeling
- Operate > Boolean > Subtract
- Area

First, select the area from which you will subtract (main body).

- Ok
Then select the areas to subtract (all 3 smaller circles)

- Ok

To add volume to the main body, we will extrude the 4 areas created.

- Preprocessor > Modeling
- Operate > Extrude > Area
- By xyz offset

The Extrude Area by Offset window should appear. First, select the orange area.

- Ok

Note: if you find no orange area, turn on the Area numbers and replot.

- PlotCtrls > Numbering > put a checkmark next to Areas numbers
- OK
- Plot > Multi-plots

The Extrude Area by XYZ Offset window should appear. Enter 0,0,-.625.

- Apply
Bell Crank
Preprocessing

Repeat the previous steps with the turquoise and violet areas.

Once the 3 circular areas have been extruded .625 inches in the negative z direction, repeat steps for all 3 circular areas extruding .625 in the positive z direction.

Your model should look similar to the one shown on the right.

Extrude the body of the bell-crank 0.1875 both in the negative z direction and the positive z direction.

Add all of the volumes created using the add Boolean operation

> Preprocessor > Modeling
> Operate > Boolean > Add
> Volumes

The Add Volumes window should appear. Select the first positive volume created and its reflected negative volume.
> Apply

Select the second positive volume created and its reflected negative volume.
> Apply

Select the third positive volume created and its reflected negative volume.
> Apply

Select the positive body volume created and its reflected negative volume.
> Apply

Select all 4 added volumes to create one final solid volume.
> Ok
We will now mesh the model.
> Preprocessor > Meshing > Mesh > Volumes > Free

The **Mesh Volumes window** should appear. Select the Volume (there should only be one at this stage of the tutorial)
> Ok

The bell crank should mesh after a few seconds. A warning window might appear. Disregard the warning and close the window.

Before applying the loads and constraints to the Crank, we will select to start a new analysis
> Solution > Analysis Type > New Analysis

For type of analysis select **static** and select Ok.
The constraints will now be added.

For this problem the inside of the center hole needs to be constrained in all six degrees of freedom.

To apply constraints select:
> Solution > Define Loads > Apply
> Structural > Displacement
> On Areas

The Apply U, ROT on Areas window should appear. Select the inside wall area of the center whole.
> Ok

The Apply U, ROT on Areas should appear. To the right of DOFs to be constrained select ALL DOF.
> Ok
The constraints now appear as shown below.

The loads will now be applied to the bell crank.

> Solutions > Define Loads > Apply  
> Structural > Force/Moment  
> On Keypoints

The Apply F/M on KP’s window should appear.

Select KP 2 in the graphics window.  
> Apply
The expanded **Apply F/M on KP’s window** should appear. From this window the direction of the force and magnitude can be specified.

Select FX for the direction of force/moment. Select Constant value for Apply as.

Enter 333 in the **Force/moment** value field which will apply a 333 lb force to the right.

Verify that all the fields match those of the figure shown to the right.

> Apply

Select KP 20 in the graphics window.

> Apply

Select FX for the Direction of force/mom. Enter 143.394 \((250\cos55^\circ)\) in the **Force/moment** value field.

> Apply

Reselect KP 20 in the graphics window.

> Apply

Select FY for the Direction of force/mom. Enter 204.788 \((250\sin55^\circ)\) in the **Force/moment** value field.

> Ok

The fully loaded and constrained model should appear similar to the picture shown aright.
The next step in completion of the tutorial is to solve the current load step that has been created. Select:

> Solution > Solve > Current LS

The **Solve Current Load Step window** will appear. To begin the analysis select **Ok**.

The analysis should begin and when complete a **Note** window should appear that states the analysis is complete.

Close both the **Note** window and **/STATUS Command** window.
Bell Crank

Results are viewed by using post processing commands.

From the ANSYS Main Menu select:
> General Postproc
> Results Viewer

From the problem statement we will estimate the maximum stress due to the force on KP 2 and KP 20. To obtain the stress, select Nodal solution, Stress and Von Mises stress.

> Nodal solution > Stress
> Von Mises stress

Select the contour icon and then select the query icon to the right of the contour icon. Click somewhere at the inner surface of the curved portion of the bell crank. The value obtain is of 3922. The outer stress is 1560. The answers are relatively close to the analytical solution (about 1% error)

The numerical value are 3880 and -1550.

Note: as you have probably noticed, the stresses are not exactly on section A-A. Not only an outer radius is not given for section A-A but the inner radius of 1” may not be well represented by the tangent to line function we used. Try resolving the problem changing the outer and inner radii.